PT-2021-14397

CVE-2021-21296

·

Published

2021-02-10

·

Updated

2026-10-06

Description by

CVSS 2.0
4.0
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions: Fleet versions prior to 3.7.0
Description: The issue allows a malicious actor with a valid node key to send a badly formatted request, causing the Fleet server to exit and resulting in denial of service. This is only possible while a live query is ongoing. The impact is considered low due to the requirement of a valid node key. There is no information disclosure, privilege escalation, or code execution.
Recommendations: For versions prior to 3.7.0, update to Fleet 3.7.0 to resolve the issue. As a temporary workaround, consider restricting access to the Fleet server to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-XWH8-9P3F-3X45
Found an issue in the description? Have something to add? Feel free to write us 👾