PT-2021-14398

CVE-2021-21298

·

Published

2021-02-26

·

Updated

2026-08-05

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions: Node-RED versions 1.2.7 and earlier
Description: The issue allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with projects.read permission can access any file via the Projects API. The vulnerability applies only to the Projects feature, which is not enabled by default in Node-RED.
Recommendations: For Node-RED versions 1.2.7 and earlier, update to Node-RED 1.2.8 to resolve the issue. As a temporary workaround, do not give untrusted users read access to the Node-RED editor.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-M33V-338H-4V9F
Found an issue in the description? Have something to add? Feel free to write us 👾