PT-2021-15256
CVE-2021-22888
·
Published
2021-03-25
·
Updated
2021-03-27
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Revive Adserver versions prior to 5.2.0
Description
The issue allows an attacker to execute injected JavaScript code by tricking a user into clicking on a specifically crafted URL. This is due to a reflected XSS vulnerability in the
status parameter of the "campaign-zone-zones.php" endpoint.Recommendations
For versions prior to 5.2.0, update to version 5.2.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the "campaign-zone-zones.php" endpoint to minimize the risk of exploitation. Avoid using the
status parameter in the affected endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾