PT-2021-15528

CVE-2021-23443

·

Published

2021-09-21

·

Updated

2022-05-03

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions edge.js versions prior to 5.3.2
Description A type confusion issue can be exploited to bypass input sanitization when the input to be rendered is an array, even if {{ }} are used. This affects the edge.js package, which is a template engine for Node.js.
Recommendations For versions prior to 5.3.2, update to version 5.3.2 or later to resolve the issue. As a temporary workaround, consider restricting the input to be rendered to strings or SafeValues to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-55R9-7MF8-M382
SNYK-JS-EDGEJS-1579556
Found an issue in the description? Have something to add? Feel free to write us 👾