PT-2021-15669

CVE-2021-24124

·

Published

2021-03-18

·

Updated

2021-03-23

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: WP Shieldon WordPress plugin versions 1.6.3 and below
Description: The issue is caused by unvalidated input and lack of output encoding in the WP Shieldon WordPress plugin, which leads to Unauthenticated Reflected Cross-Site Scripting (XSS) when the CAPTCHA page is shown. This could potentially lead to privileged escalation.
Recommendations: For WP Shieldon WordPress plugin versions 1.6.3 and below, update to a version above 1.6.3 to resolve the issue. As a temporary workaround, consider restricting access to the CAPTCHA page until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾