PT-2021-15746
CVE-2021-24201
·
Published
2021-04-05
·
Updated
2021-04-09
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions:
Elementor Website Builder WordPress plugin versions prior to 3.1.4
Description:
The issue concerns the column element in the Elementor Website Builder WordPress plugin, where a user with Contributor or above permissions can manipulate the
html tag parameter to inject JavaScript. This JavaScript is not filtered and is output without escaping, leading to its execution when the saved page is viewed or previewed.Recommendations:
For versions prior to 3.1.4, update to version 3.1.4 or later to resolve the issue. As a temporary workaround, consider restricting the ability to modify the
html tag parameter for users with Contributor or above permissions until the update is applied.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾