PT-2021-15762

CVE-2021-24218

·

Published

2021-04-12

·

Updated

2021-04-20

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Facebook for WordPress plugin versions prior to 3.0.4
Description: The issue concerns the wp ajax save fbe settings and wp ajax delete fbe settings AJAX actions, which were vulnerable to CSRF due to a lack of nonce protection. Additionally, the settings in the saveFbeSettings function had no sanitization, allowing for script tags to be saved.
Recommendations: For versions prior to 3.0.4, update to version 3.0.4 or later to resolve the issue. As a temporary workaround, consider disabling the wp ajax save fbe settings and wp ajax delete fbe settings AJAX actions until a patch is available. Restrict access to the saveFbeSettings function to minimize the risk of exploitation. Avoid using the settings in the saveFbeSettings function that allow for script tags to be saved until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾