PT-2021-15841
CVE-2021-24304
·
Published
2021-08-09
·
Updated
2021-08-17
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Newsmag WordPress theme versions prior to 5.0
Description
The issue is related to an unauthenticated Reflected Cross-site Scripting (XSS) vulnerability. This occurs because the
td block id parameter in the td ajax block AJAX action is not properly sanitized.Recommendations
For versions prior to 5.0, update to version 5.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the
td ajax block AJAX action to minimize the risk of exploitation. Avoid using the td block id parameter in the affected AJAX endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾