PT-2021-15851
CVE-2021-24314
·
Published
2021-05-17
·
Updated
2021-05-24
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Goto WordPress theme versions prior to 2.1
Description
The issue arises from the lack of sanitization, validation, or escaping of the
keywords GET parameter from the listing page, which is then used in a SQL statement. This leads to an unauthenticated SQL injection issue.Recommendations
For Goto WordPress theme versions prior to 2.1, update to version 2.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the listing page or disabling the use of the
keywords parameter in SQL statements until the update is applied.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾