PT-2021-15884

CVE-2021-24348

·

Published

2021-06-14

·

Updated

2021-06-21

Description by

CVSS 3.1
7.2
High
MetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Side Menu – add fixed side buttons WordPress plugin versions prior to 3.1.5
Description The issue concerns the menu delete functionality, which is accessible to Administrator users. It takes the did GET parameter and uses it in an SQL statement without proper sanitization, validation, or escaping, leading to a SQL Injection issue.
Recommendations For versions prior to 3.1.5, update to version 3.1.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the menu delete functionality to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾