PT-2021-15893
CVE-2021-24357
·
Published
2021-06-14
·
Updated
2021-06-18
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
FooGallery WordPress plugin versions prior to 2.0.35
Description
The issue arises from the Custom CSS field of each gallery not being properly sanitised or validated before being output in the page where the gallery is embedded, leading to a stored Cross-Site Scripting issue.
Recommendations
For versions prior to 2.0.35, update to version 2.0.35 or later to resolve the issue. As a temporary workaround, consider disabling the Custom CSS field for each gallery until the update is applied. Restrict access to the gallery embedding feature to minimize the risk of exploitation. Avoid using the Custom CSS field in the affected plugin until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾