PT-2021-15907

CVE-2021-24372

·

Published

2021-06-21

·

Updated

2021-06-25

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WP Hardening – Fix Your WordPress Security WordPress plugin versions prior to 1.2.2
Description The issue is related to a reflected Cross-Site Scripting problem. It occurs because the $ SERVER['REQUEST URI'] is not properly sanitised or escaped before being outputted in an attribute. This leads to a security issue where an attacker could potentially inject malicious scripts.
Recommendations For versions prior to 1.2.2, update to version 1.2.2 or later to resolve the issue. As a temporary workaround, consider implementing proper sanitisation and escaping of the $ SERVER['REQUEST URI'] variable to prevent Cross-Site Scripting attacks.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾