PT-2021-15953
CVE-2021-24421
·
Published
2021-07-12
·
Updated
2021-07-15
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
WP JobSearch WordPress plugin versions prior to 1.7.4
Description
The issue allows low privilege users to use JavaScript payloads in parameters from the my-resume page, leading to a Stored Cross-Site Scripting issue. This is because the plugin did not sanitise or escape multiple of its parameters before outputting them in the page.
Recommendations
For WP JobSearch WordPress plugin versions prior to 1.7.4, update to version 1.7.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the my-resume page to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾