PT-2021-15960
CVE-2021-24430
·
Published
2021-08-02
·
Updated
2021-08-10
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Speed Booster Pack PageSpeed Optimization Suite WordPress plugin versions prior to 4.2.0
Description
The issue arises from the plugin not validating its
caching exclude urls and caching include query strings settings before outputting them in a PHP file, which could lead to remote code execution (RCE).Recommendations
For versions prior to 4.2.0, update to version 4.2.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the settings that handle
caching exclude urls and caching include query strings to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾