PT-2021-15968

CVE-2021-24440

·

Published

2021-07-12

·

Updated

2021-07-15

Description by

CVSS 3.1
4.8
Medium
MetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Sign-up Sheets WordPress plugin versions prior to 1.0.14
Description The issue allows high privilege users to add JavaScript in certain fields when creating a new sheet, leading to a Stored Cross-Site Scripting issue. The payloads will be triggered when viewing the 'All Sheets' page in the admin dashboard.
Recommendations For versions prior to 1.0.14, update to version 1.0.14 or later to resolve the issue. As a temporary workaround, consider restricting access to the 'All Sheets' page in the admin dashboard to minimize the risk of exploitation. Avoid using the affected fields when creating a new sheet until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾