PT-2021-15970

CVE-2021-24442

·

Published

2021-07-12

·

Updated

2021-07-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Poll, Survey, Questionnaire and Voting system WordPress plugin versions prior to 1.5.3
Description The issue allows unauthenticated users to perform SQL Injection attacks due to the lack of sanitization, escaping, or validation of the date answers[] POST parameter when sending a Poll result.
Recommendations For versions prior to 1.5.3, update to version 1.5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the Poll result functionality until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾