PT-2021-15998

CVE-2021-24474

·

Published

2021-08-02

·

Updated

2021-11-10

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Awesome Weather Widget WordPress plugin versions prior to 3.0.3
Description The issue is related to an unauthenticated Reflected Cross-Site Scripting (XSS) vulnerability. It occurs because the id parameter of the awesome weather refresh AJAX action is not properly sanitized.
Recommendations For Awesome Weather Widget WordPress plugin versions prior to 3.0.3, update to version 3.0.3 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾