PT-2021-16006
CVE-2021-24483
·
Published
2021-08-02
·
Updated
2021-08-10
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Poll Maker WordPress plugin versions prior to 3.2.1
Description
The issue concerns the
get poll categories(), get polls(), and get reports() functions, which did not properly validate the orderby parameter before using it in SQL statements. This oversight led to SQL injection issues in the admin dashboard.Recommendations
For versions prior to 3.2.1, update to version 3.2.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the
get poll categories(), get polls(), and get reports() functions until a patch is applied. Avoid using the orderby parameter in the affected functions until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾