PT-2021-16034
CVE-2021-24512
·
Published
2021-08-16
·
Updated
2021-08-23
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Video Posts Webcam Recorder WordPress plugin versions prior to 3.2.4
Description
The issue is an authenticated reflected cross site scripting (XSS) vulnerability in one of the administrative functions for handling deletion of videos. This means that an attacker could potentially inject malicious code into the website, which would then be executed by the user's browser, allowing the attacker to steal user data or take control of the user's session.
Recommendations
For versions prior to 3.2.4, update to version 3.2.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the administrative functions for handling video deletion until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾