PT-2021-16046
CVE-2021-24524
·
Published
2021-08-23
·
Updated
2021-08-26
Description by
CVSS 3.1
4.8
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
GiveWP – Donation Plugin and Fundraising Platform versions prior to 2.12.0
Description
The issue allows high privilege users to use Cross-Site Scripting payloads in the Donation Level setting of its Donation Forms due to a lack of proper escaping. This could potentially lead to security issues, but specific details about the number of affected devices or real-world incidents are not provided.
Recommendations
For versions prior to 2.12.0, update to version 2.12.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the Donation Forms for high privilege users until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾