PT-2021-16051
CVE-2021-24529
·
Published
2021-08-23
·
Updated
2021-08-26
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Grid Gallery – Photo Image Grid Gallery WordPress plugin versions prior to 1.2.5
Description
The issue arises from the improper sanitization of the title field for image galleries when added via the admin dashboard, resulting in an authenticated Stored Cross-Site Scripting issue. This allows attackers to inject malicious scripts into the website.
Recommendations
For versions prior to 1.2.5, update to version 1.2.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the admin dashboard to minimize the risk of exploitation. Avoid using the title field for image galleries in the admin dashboard until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾