PT-2021-16085
CVE-2021-24568
·
Published
2021-09-06
·
Updated
2021-09-09
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
AddToAny Share Buttons WordPress plugin versions prior to 1.7.46
Description
The issue allows high privilege users, such as admins, to perform Cross-Site Scripting attacks. This is possible because the plugin does not sanitize its Sharing Header setting when outputting it in frontend pages, even when the unfiltered html capability is disallowed.
Recommendations
For versions prior to 1.7.46, update to version 1.7.46 or later to resolve the issue. As a temporary workaround, consider restricting the ability to modify the Sharing Header setting to trusted users only.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾