PT-2021-16086
CVE-2021-24569
·
Published
2021-09-27
·
Updated
2021-10-04
Description by
CVSS 3.1
4.8
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Cookie Notice & Compliance for GDPR / CCPA WordPress plugin versions prior to 2.1.2
Description
The issue allows high privilege users, such as admins, to perform Cross-Site Scripting (XSS) attacks even when the unfiltered html capability is disallowed. This is due to the plugin not escaping the value of its Button Text setting when outputting it in an attribute in the frontend.
Recommendations
For versions prior to 2.1.2, update to version 2.1.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the Button Text setting to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾