PT-2021-16091
CVE-2021-24575
·
Published
2021-11-08
·
Updated
2021-11-10
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WPSchoolPress WordPress plugin versions prior to 2.1.10
Description
The issue arises from the improper sanitization or use of prepared statements for POST variables in SQL queries, leading to SQL injection. This affects multiple actions available to various authenticated users, including subscribers, students, teachers, and those with higher privileges.
Recommendations
For versions prior to 2.1.10, update to version 2.1.10 or later to resolve the issue. As a temporary workaround, consider restricting access to actions that utilize POST variables in SQL queries until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾