PT-2021-16098
CVE-2021-24582
·
Published
2021-09-20
·
Updated
2021-09-29
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
ThinkTwit WordPress plugin versions prior to 1.7.1
Description
The issue is related to a Stored Cross-Site Scripting problem. It occurs because the
Consumer key setting is not properly sanitised or escaped before being outputted on its settings page.Recommendations
For versions prior to 1.7.1, update to version 1.7.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the settings page to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾