PT-2021-16101

CVE-2021-24585

·

Published

2021-09-20

·

Updated

2021-10-01

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions The Timetable and Event Schedule WordPress plugin versions prior to 2.4.0
Description The issue allows low-privilege users with the edit posts capability to retrieve sensitive user data, including hashed passwords, usernames, and email addresses, by requesting event Timeslot data and iterating over the user id. This can be combined with another issue where an arbitrary user ID can be set, potentially allowing unauthorized access to sensitive information.
Recommendations For versions prior to 2.4.0, update to version 2.4.0 or later to resolve the issue. As a temporary workaround, consider restricting the edit posts capability to high-privilege users until the update is applied. Restrict access to the event Timeslot data to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾