PT-2021-16106
CVE-2021-24591
·
Published
2021-09-06
·
Updated
2021-09-09
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Highlight WordPress plugin versions prior to 0.9.3
Description
The issue allows high privilege users to perform Cross-Site Scripting attacks due to the lack of sanitization in the CustomCSS setting, even when the unfiltered html capability is disallowed.
Recommendations
For versions prior to 0.9.3, update to version 0.9.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the CustomCSS setting to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾