PT-2021-16116
CVE-2021-24601
·
Published
2021-09-06
·
Updated
2021-09-09
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
WPFront Notification Bar WordPress plugin version 2.1.0.08087 and earlier
Description
The issue arises from the plugin's failure to properly sanitise and escape its settings. This could allow high privilege users to perform Cross-Site Scripting attacks, even when the unfiltered html capability is disallowed.
Recommendations
For versions prior to 2.1.0.08087, update to version 2.1.0.08087 or later to resolve the issue. As a temporary workaround, consider restricting access to the plugin's settings to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾