PT-2021-16153

CVE-2021-24637

·

Published

2021-09-20

·

Updated

2021-10-01

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Google Fonts Typography WordPress plugin versions prior to 3.0.3
Description The issue allows users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks. This is possible due to the lack of proper escaping and sanitization of some block settings. The attack can be performed via the blockType (combined with content), align, color, variant, and fontID arguments of a Gutenberg block.
Recommendations For versions prior to 3.0.3, update to version 3.0.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the Gutenberg block settings to minimize the risk of exploitation. Avoid using the blockType, align, color, variant, and fontID arguments in the affected block until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾