PT-2021-16225
CVE-2021-24722
·
Published
2021-11-01
·
Updated
2021-11-30
Description by
CVSS 3.1
4.8
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Restaurant Menu by MotoPress WordPress plugin versions prior to 2.4.2
Description
The issue concerns a lack of proper sanitization or escaping of inputs when creating new menu items, potentially allowing high-privilege users to perform Cross-Site Scripting attacks, even when the unfiltered html capability is disallowed.
Recommendations
For versions prior to 2.4.2, update to version 2.4.2 or later to resolve the issue. As a temporary workaround, consider restricting the creation of new menu items to trusted users until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾