PT-2021-16249
CVE-2021-24748
·
Published
2021-11-29
·
Updated
2021-11-29
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
The Email Before Download WordPress plugin versions prior to 6.8
Description:
The issue arises from the improper validation and escaping of the
order and orderby GET parameters before using them in SQL statements, leading to authenticated SQL injection issues.Recommendations:
For versions prior to 6.8, update to version 6.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the affected API endpoints that utilize the
order and orderby parameters until a patch is available. Avoid using the order and orderby parameters in affected SQL statements until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾