PT-2021-16256
CVE-2021-24755
·
Published
2021-11-29
·
Updated
2025-10-17
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
myCred WordPress plugin versions prior to 2.3
Description:
The issue concerns an SQL injection that occurs because the
fields parameter is not validated or escaped before being used in a SQL statement. This can be exploited by any authenticated user.Recommendations:
For versions prior to 2.3, update to version 2.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the SQL statement that uses the
fields parameter until a patch is available. Avoid using the fields parameter in SQL statements until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾