PT-2021-16293

CVE-2021-24798

·

Published

2021-11-08

·

Updated

2021-11-10

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: WP Header Images WordPress plugin versions prior to 2.0.1
Description: The issue is related to a Reflected Cross-Site Scripting problem. It occurs because the t parameter is not properly sanitised and escaped before being outputted back in the plugin's settings page.
Recommendations: For WP Header Images WordPress plugin versions prior to 2.0.1, update to version 2.0.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the plugin's settings page to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾