PT-2021-16327
CVE-2021-24846
·
Published
2021-12-21
·
Updated
2021-12-27
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Ni WooCommerce Custom Order Status WordPress plugin versions prior to 1.9.7
Description:
The issue concerns the
get query() function, which does not properly sanitise the sort parameter before using it in a SQL statement. This leads to an SQL injection, which can be exploited by any authenticated users, such as subscribers. The niwoocos ajax AJAX action is used by the vulnerable function and is available to all authenticated users.Recommendations:
For versions prior to 1.9.7, update to version 1.9.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the
niwoocos ajax AJAX action to minimize the risk of exploitation. Avoid using the sort parameter in the affected AJAX endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾