PT-2021-16348

CVE-2021-24875

·

Published

2021-11-23

·

Updated

2021-11-24

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: eCommerce Product Catalog Plugin for WordPress versions prior to 3.0.39
Description: The issue is related to a Reflected Cross-Site Scripting problem. It occurs because the ic-settings-search parameter is not properly escaped before being outputted back in the page in an attribute. This can lead to malicious script execution.
Recommendations: For versions prior to 3.0.39, update to version 3.0.39 or later to resolve the issue. As a temporary workaround, consider restricting access to the ic-settings-search parameter to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾