PT-2021-16350
CVE-2021-24877
·
Published
2021-11-23
·
Updated
2021-11-26
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
MainWP Child WordPress plugin versions prior to 4.1.8
Description:
The issue concerns an SQL injection that occurs due to the lack of validation of the
orderby and order parameters before they are used in a SQL statement. This can be exploited by high-privilege users, such as admins, when a specific plugin, Backup and Staging by WP Time Capsule, is installed.Recommendations:
For versions prior to 4.1.8, update to version 4.1.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the
orderby and order parameters in SQL statements until the update is applied.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾