PT-2021-16720

CVE-2021-25641

·

Published

2021-05-29

·

Updated

2022-03-18

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Dubbo versions prior to 2.7.8 Apache Dubbo versions prior to 2.6.9
Description The issue allows an attacker to choose the serialization id used by the Provider, bypassing the server's instruction. This can lead to exploitation if a weak deserializer, such as Kryo or FST, is in the code scope. A remote unauthenticated attacker can exploit this weakness.
Recommendations For Apache Dubbo versions prior to 2.7.8, update to version 2.7.8 or later. For Apache Dubbo versions prior to 2.6.9, update to version 2.6.9 or later. As a temporary workaround, consider disabling the use of weak deserializers, such as Kryo and FST, until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-V2RG-8CWR-75G8
Found an issue in the description? Have something to add? Feel free to write us 👾