PT-2021-17247

CVE-2021-27098

·

Published

2021-03-05

·

Updated

2021-05-21

Description by

CVSS 3.1
8.1
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions: SPIRE versions 0.8.1 through 0.8.4 SPIRE versions prior to 0.9.4 SPIRE versions prior to 0.10.2 SPIRE versions prior to 0.11.3 SPIRE versions prior to 0.12.1
Description: Specially crafted requests to the "FetchX509SVID RPC" of SPIRE Server’s Legacy Node API can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this issue.
Recommendations: For SPIRE versions 0.8.1 through 0.8.4, upgrade to version 0.8.5 or later. For SPIRE versions prior to 0.9.4, upgrade to version 0.9.4 or later. For SPIRE versions prior to 0.10.2, upgrade to version 0.10.2 or later. For SPIRE versions prior to 0.11.3, upgrade to version 0.11.3 or later. For SPIRE versions prior to 0.12.1, upgrade to version 0.12.1 or later. As a temporary workaround, consider restricting access to the "FetchX509SVID RPC" of SPIRE Server’s Legacy Node API until a patch is available.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-H746-RM5Q-8MGQ
Found an issue in the description? Have something to add? Feel free to write us 👾