PT-2021-17448
CVE-2021-27413
·
Published
2021-05-13
·
Updated
2021-05-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Omron CX-One versions 4.60 and prior
Omron CX-Server versions 5.0.29.0 and prior
Description
The issue is a stack-based buffer overflow, which may allow an attacker to execute arbitrary code. This occurs during the parsing of NCI files in the CX-Position component of Omron CX-One.
Recommendations
For Omron CX-One versions 4.60 and prior, update to a version later than 4.60 to resolve the issue.
For Omron CX-Server versions 5.0.29.0 and prior, update to a version later than 5.0.29.0 to resolve the issue.
As a temporary workaround, consider restricting access to the NCI file parsing functionality in the CX-Position component until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾