PT-2021-17770
CVE-2021-28144
·
Published
2021-03-11
·
Updated
2021-04-23
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions:
D-Link DIR-3060 versions prior to 1.11b04 HF2
Description:
The issue allows remote authenticated users to inject arbitrary commands in an admin or root context. This is because
SetVirtualServerSettings calls CheckArpTables, which calls popen unsafely. There is no information provided about the estimated number of potentially affected devices worldwide or real-world incidents where this issue was exploited.Recommendations:
For D-Link DIR-3060 versions prior to 1.11b04 HF2, update to version 1.11b04 HF2 or later to resolve the issue. As a temporary workaround, consider restricting access to the
prog.cgi interface until a patch is applied. Avoid using the SetVirtualServerSettings function, which calls CheckArpTables, until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾