PT-2021-18211
CVE-2021-29435
·
Published
2021-04-13
·
Updated
2021-04-19
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions:
trestle-auth versions 0.4.0 through 0.4.1
Description:
A vulnerability in trestle-auth allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials.
Recommendations:
For versions 0.4.0 and 0.4.1, update to trestle-auth 0.4.2 to fix the vulnerability.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾