PT-2021-18589

CVE-2021-30056

·

Published

2021-04-05

·

Updated

2021-04-08

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Knowage Suite versions prior to 7.4
Description The issue allows an attacker to inject arbitrary web script in "/restful-services/publish" via the EXEC FROM parameter, which can lead to data leakage. This is a case of reflected cross-site scripting (XSS).
Recommendations For versions prior to 7.4, update to version 7.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/restful-services/publish" endpoint to minimize the risk of exploitation. Avoid using the EXEC FROM parameter in the affected API endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾