PT-2021-18591

CVE-2021-30058

·

Published

2021-04-05

·

Updated

2021-04-08

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Knowage Suite versions prior to 7.4
Description The issue allows an attacker to inject arbitrary external scripts via the SBI HOST parameter in the "/knowagecockpitengine/api/1.0/pages/execute" API endpoint, leading to cross-site scripting (XSS).
Recommendations For versions prior to 7.4, as a temporary workaround, consider restricting access to the "/knowagecockpitengine/api/1.0/pages/execute" API endpoint and avoid using the SBI HOST parameter until a patch is available. Update to version 7.4 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾