PT-2021-18765

CVE-2021-30502

·

Published

2021-04-25

·

Updated

2021-05-07

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions vscode-ghc-simple extension versions prior to 0.2.3
Description The issue allows remote code execution via a crafted workspace configuration with replCommand. This can be exploited by an attacker to execute malicious code.
Recommendations For versions prior to 0.2.3, update to version 0.2.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the replCommand in workspace configurations until the update is applied.
Exploitability
Fix
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾