PT-2021-19499
CVE-2021-31776
·
Published
2021-04-29
·
Updated
2021-05-13
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Aviatrix VPN Client versions prior to 2.14.14
Description
The issue is related to an unquoted search path in the Aviatrix VPN Client, which can enable local privilege escalation to the SYSTEM user. This occurs if the machine is misconfigured, allowing unprivileged users to write to directories that are supposed to be restricted to administrators.
Recommendations
For versions prior to 2.14.14, update to version 2.14.14 or later to resolve the issue. As a temporary workaround, consider restricting write access to directories that are supposed to be restricted to administrators to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾