PT-2021-19686
CVE-2021-32281
·
Published
2021-09-20
·
Updated
2021-10-02
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
gravity versions prior to 0.8.2
Description:
A heap-buffer-overflow issue exists in the
gnode function add upvalue function located in gravity ast.c, allowing an attacker to cause code execution.Recommendations:
For versions prior to 0.8.2, update to version 0.8.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the
gnode function add upvalue function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾