PT-2021-19783

CVE-2021-32561

·

Published

2021-05-11

·

Updated

2022-05-24

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions OctoPrint versions prior to 1.6.0
Description The issue allows for XSS because API error messages include the values of input parameters, such as username or other user-provided data. This can lead to malicious scripts being executed on the client-side.
Recommendations For versions prior to 1.6.0, update to version 1.6.0 or later to resolve the issue. As a temporary workaround, consider restricting access to API endpoints that include user-provided input parameters in error messages until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-VCX4-FPMP-MVV6
PYSEC-2021-30
Found an issue in the description? Have something to add? Feel free to write us 👾