PT-2021-19868

CVE-2021-32702

·

Published

2021-06-25

·

Updated

2021-07-01

Description by

CVSS 3.1
8.0
High
MetricsAV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions @auth0/nextjs-auth0 versions prior to 1.4.2
Description The issue concerns a reflected XSS vulnerability. An attacker can execute arbitrary code by providing an XSS payload in the error query parameter, which is then processed by the callback handler as an error message. Users are affected if they are using @auth0/nextjs-auth0 version 1.4.1 or lower, unless they are using custom error handling that does not return the error message in an HTML response.
Recommendations Upgrade to version 1.4.2 to resolve the issue. The fix adds basic HTML escaping to the error message. As a temporary workaround, consider using custom error handling that does not return the error message in an HTML response to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-954C-JJX6-CXV7
Found an issue in the description? Have something to add? Feel free to write us 👾