PT-2021-19935
CVE-2021-32793
·
Published
2021-08-04
·
Updated
2021-08-12
Description by
CVSS 3.1
5.7
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:H
Name of the Vulnerable Software and Affected Versions
Pi-hole Web Interface versions prior to 5.5.1
Description
The Pi-hole Web interface has a stored cross-site-scripting vulnerability in the function to add domains to blocklists or allowlists. This vulnerability exists because user input added as a wildcard domain to a blocklist or allowlist is unfiltered in the web interface, allowing for a persistent XSS vulnerability. A remote attacker can attack administrative user accounts through client-side attacks.
Recommendations
For versions prior to 5.5.1, update to Pi-hole Web Interface version 5.5.1 to resolve the issue. As a temporary workaround, consider restricting access to the blocklist and allowlist functions until the update is applied. Avoid using unfiltered user input as wildcard domains in blocklists or allowlists until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾