PT-2021-20317

CVE-2021-3377

·

Published

2021-03-05

·

Updated

2025-11-03

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: ansi up versions prior to 5.0.0
Description: The npm package ansi up is affected by a cross-site scripting (XSS) vulnerability due to insufficient URL sanitization when converting ANSI escape codes into HTML. This issue allows ANSI escape codes to create HTML hyperlinks.
Recommendations: For versions prior to 5.0.0, update to version 5.0.0 to resolve the issue. As a temporary workaround, consider disabling the feature that allows ANSI escape codes to create HTML hyperlinks until the update is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-2V5F-23XC-V9QR
Found an issue in the description? Have something to add? Feel free to write us 👾